Supervisorをpip3でインストールしようとしたら、怒られたでござる


$ sudo pip3 install supervisor
Collecting supervisor
Downloading supervisor-3.1.3.tar.gz (391kB)
100% |████████████████████████████████| 393kB 1.3MB/s
Complete output from command python setup.py egg_info:
Supervisor requires Python 2.4 or later but does not work on any version of Python 3. You are using version 3.4.3 (default, May 9 2015, 12:06:31)
[GCC 4.8.2 20140120 (Red Hat 4.8.2-16)]. Please install using a supported version.
----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-n73cd8cg/supervisor

見事に怒られました(>_<) Python 3系には対応してないみたいです。。。 supervisord for python 3? – Stack Overflow
によると、4.0からは対応するみたい。でそれまでは、
supervisor-py3k
を使え的なことが書いてあります。

supervisord for python 3? – | Sybil
にも書いてありました。

ということで、4.0待ちかなと思います。